package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\balmdrasa\b\s+\b\w{3,}\b`)
var str = `almdrasa is your way to learn programming the right way. almdrasa badges motivate students to do more. almdrasa quizes help students practice on what they have learned through the course. almdrasa courses are one of a kind because they were made by professionals. almdrasa look and feel is one of a kind. almdrasa wishes you a good learning. thanks.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}