$re = '/{"refunded_amount":(?<amt>[0-9]+)\,\"reference":"(?<ref>[0-9]+)\"}/m';
$str = '{"refunded_amount":1356,"reference":"765000603"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);