#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(?=(\d)\d)(?<![\d\-\x{2013}\x{2014}%])(?!000|666|9\d\d|\d{3}00|\d{5}0000|\1{9}|012345678|123456789|234567890|098765432|876543210|078051120|219099999)\d{9}(?![\d\-\x{2013}\x{2014}%])(?!\.(?:pdf|docx?|xlsx?|pptx?|zip|jpe?g|png|txt|log)\b)"
Local $sString = "################" & @CRLF & _
"## Must match:" & @CRLF & _
"################" & @CRLF & _
"" & @CRLF & _
"009958881" & @CRLF & _
"123454891 is my ssn" & @CRLF & _
"my ssn is 123454891" & @CRLF & _
"my ssn is 123454891 ok?" & @CRLF & _
"my ssn is 123454891." & @CRLF & _
"my ssn is:123454891." & @CRLF & _
"" & @CRLF & _
"# This one sneaks though, but we can live with that, maybe?" & @CRLF & _
"myssnnumberis123454891ok?" & @CRLF & _
"" & @CRLF & _
"################" & @CRLF & _
"## Must not match:" & @CRLF & _
"################" & @CRLF & _
"" & @CRLF & _
"# All-Zero group sequences" & @CRLF & _
"231840000" & @CRLF & _
"231007289" & @CRLF & _
"000877289" & @CRLF & _
"" & @CRLF & _
"# Starting with 9" & @CRLF & _
"908780485" & @CRLF & _
"" & @CRLF & _
"# Starting with 666" & @CRLF & _
"666780485" & @CRLF & _
"" & @CRLF & _
"# Same number sequences:" & @CRLF & _
"222222222" & @CRLF & _
"555555555" & @CRLF & _
"" & @CRLF & _
"# Ascending/Descending sequences:" & @CRLF & _
"123456789" & @CRLF & _
"87654321" & @CRLF & _
"" & @CRLF & _
"# Known invalidated SSN:" & @CRLF & _
"219099999" & @CRLF & _
"078051120" & @CRLF & _
"" & @CRLF & _
"# File names with common extensions:" & @CRLF & _
"123454891.pdf" & @CRLF & _
"123454891.xlsx" & @CRLF & _
"Check the attachment: 123454891.xls, then get back to me." & @CRLF & _
"Check the attachment: 123454891.jpeg, then get back to me." & @CRLF & _
"" & @CRLF & _
"# Extra digits:" & @CRLF & _
"1123454891" & @CRLF & _
"1234548911" & @CRLF & _
"" & @CRLF & _
"# Unsupported boundaries:" & @CRLF & _
"–123454891" & @CRLF & _
"—123454891" & @CRLF & _
"%123454891" & @CRLF & _
"123454891-" & @CRLF & _
"123454891—" & @CRLF & _
"123454891%" & @CRLF & _
"1-123454891" & @CRLF & _
"123454891-1" & @CRLF & _
"" & @CRLF & _
"# Valid SSN with separators:" & @CRLF & _
"123-45-4891" & @CRLF & _
"098-18-6564" & @CRLF & _
"123-45-4848" & @CRLF & _
"702-02-0202" & @CRLF & _
"001-14-0004" & @CRLF & _
"009 95 8881" & @CRLF & _
"123-45-4891 is my ssn" & @CRLF & _
"my ssn is 123-45-4891" & @CRLF & _
"my ssn is 123-45-4891 ok?" & @CRLF & _
"my ssn is 123-45-4891." & @CRLF & _
"123 45 4891 is my ssn" & @CRLF & _
"my ssn is 123 45 4891" & @CRLF & _
"my ssn is 123 45 4891 ok?" & @CRLF & _
"my ssn is 123 45 4891." & @CRLF & _
"my ssn is:123-45-4891." & @CRLF & _
"my ssn is:123 45 4891." & @CRLF & _
"ss#123-45-4891" & @CRLF & _
"ssn123-45-4891" & @CRLF & _
"" & @CRLF & _
"# Emdash separator:" & @CRLF & _
"123–45–4891" & @CRLF & _
"" & @CRLF & _
"# Endash separator:" & @CRLF & _
"123—45—4891" & @CRLF & _
"" & @CRLF & _
"# Slash separator" & @CRLF & _
"123/45/4891" & @CRLF & _
"" & @CRLF & _
"# Telephone" & @CRLF & _
"1-234-567-8901" & @CRLF & _
"1-234-567-8901" & @CRLF & _
"1-234-567-8901 " & @CRLF & _
"1 (234) 567-8901" & @CRLF & _
"12347658901" & @CRLF & _
"" & @CRLF & _
"# Credit card " & @CRLF & _
"5500 0000 0000 0004" & @CRLF & _
"3400 0000 0000 009" & @CRLF & _
"3000 0000 0000 04" & @CRLF & _
"5500-1244-2232-0004" & @CRLF & _
"3400-1244-0000-009" & @CRLF & _
"3000-1244-1234-04" & @CRLF & _
"" & @CRLF & _
"# Random Numbers" & @CRLF & _
"1234567890112371298739872891738912738937289d712897381297381927d3128937893d7218947d1892742189duc89789v127c897412987893c12893c79" & @CRLF & _
"122-426-389" & @CRLF & _
"187-5-43212" & @CRLF & _
"187-0-43212" & @CRLF & _
"2423-45-6789" & @CRLF & _
"" & @CRLF & _
"# Unsupported boundaries:" & @CRLF & _
"ssn-123-45-4891" & @CRLF & _
"123-45-4891-ssn" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")