package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)org.alluxio<name="*([a-zA-Z_\.]+)\.([0-9\.]+)"*,*[^:,\n]*><>(\w+)Rate`)
var str = `org.alluxio<name=Master.GetFingerprint.UFS:s3a:%2F%2Frzp-si-dashboard%2F.UFS_TYPE:s3, type=timers><>50thPercentile
org.alluxio<name=Master.registerMaster.User:alluxio
org.alluxio<name=Master.EmbeddedJournalSnapshotReplayTimer, type=timers><>50thPercentile
org.alluxio<name=Master.InodeCacheEvictions, type=counters><>Count
org.alluxio<name="Master.getConfigHash.User:trino:afd", type=counters><>Count
org.alluxio<name=Master.GetSpace.User:alluxio.UFS:s3:%2F%2Frzp-edh-prod%2Falluxio%2Falluxio-dev.UFS_TYPE:s3.fd, type=timers><>50thPercentile
org.alluxio<name=Master.GetSpace.User:alluxio.UFS:s3:%2F%2Frzp-edh-prod%2Falluxio%2Falluxio-dev.UFS_TYPE:s3.fd><>50thPercentile
org.alluxio<name=Master.JournalGainPrimacyTimer, type=timers><>50thPercentile
org.alluxio<name="Master.UfsSessionCount-Ufs:s3:%2F%2Frzp-prod-datum%2Fpa_sheets%2FXFinopsIncidentTracker%2FIncidentTracker"><>Count
org.alluxio<name=Worker.BytesReadRemoteThroughput.10.44.21.20, type=meters><>OneMinuteRate`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}