re = /[^A-MO-RT-Za-mo-rt-z0-9 !@#$%^&*()_+\-={};':\"\\|,.<>\/?¡-ÿ]/m
str = 'não sim Sim SIM NÃO Yes No'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end