$re = '/^(%data:([^,.]+)[.,|\/](?:ROW)\[(\d+)\][.,|\/]([^.,]+)%)$/i';
$str = '%data:ResultsetName,row[3].BlaBla%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);