import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*((public|private|protected)? *(static)? *(void|int|String|boolean|float|double) +[a-zA-Z_](\\w)* *[\\(] *(((int|String|boolean|float|double) +[a-zA-Z_](\\w)*))* *( *, *int +[a-zA-Z_](\\w)* *| *, *String +[a-zA-Z_](\\w)* *| *, *boolean +[a-zA-Z_](\\w)* *| *, *float +[a-zA-Z_](\\w)* *| *, *double +[a-zA-Z_](\\w)* *|\\))+\\s*[\\{]\\s*|( *public +static +void +main *\\( *String *(\\[\\])? * args *(\\[\\])? *\\)\\s*[\\{]\\s*))";
final String string = "public static void salud(String hola,boolean siu) {\n"
+ "void ultimo(int hola){\n"
+ "public void saludos(){\n"
+ "void numeros(String cola, int hola, String si){\n"
+ "public static void main(String[] args){\n"
+ "protected String idnombre (int n){\n"
+ "protected void prueba(String a,int b){\n"
+ "public static void main(String[] args[]){\n"
+ "public static void main(String args[]){\n"
+ "void hola(){}\n"
+ "void hola(){\n"
+ "public void main(String id)\n"
+ "{\n\n\n"
+ "public void hola ( int c)\n"
+ "{";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}