import Foundation
let pattern = #".*tax"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Year
Qtr
CASH FLOWS FROM OPERATING ACTIVITIES
Profit before tax
Depreciation of property, plant and equipment
Interest expense
Unrealised gain on foreign exchange
Interest income
Gain on disposal of property, plant and equipment
Writeback of allowance for impairment losses on trade receivables
Plant and equipment written off
Allowance for impairment losses on receivables
Bad debt written off
Gain on disposal of an associate
Share of results of associates
Operating profit before working capital changes
Inventories
Trade receivables
Other receivables, deposits and prepaid expenses
Amount owing by an associate
Trade payables
Other payables and accrued expenses
Cash generated from operations
Taxes paid
Net cash from operating activities
CASH FLOWS FOR INVESTING ACTIVITIES
Interest received
Additional investment of a subsidiary
Purchase of property, plant and equipment
Proceeds from disposal of property, plant and equipment
Proceeds from disposal of an associate
Net (placement)/withdrawal of fixed deposits with licensed banks
Net cash for investing activities
CASH FLOWS FOR FINANCING ACTIVITIES
Interest paid
Dividend paid by the Company
Dividend paid by a subsidiary to non-controlling interests
Repayment of term loans
Payment of lease liabilities
Net cash for financing activities
NET INCREASE IN CASH AND CASH EQUIVALENTS
CASH AND CASH EQUIVALENTS AT BEGINNING OF FINANCIAL YEAR
EFFECT OF EXCHANGE DIFFERENCES
CASH AND CASH EQUIVALENTS AT END OF FINANCIAL YEAR
THE CASH AND CASH EQUIVALENTS COMPRISE
Cash and bank balances
Fixed deposits with licensed banks
Short-term investments
Less: Fixed deposits pledged with banks
Less: Fixed deposits with maturity more than 3 months
Cash and cash equivalents
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)