# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\w\+\-]+\.\w+\.(?<EPOCH>\d+)(?<AV>\.av)?\.mat"
test_str = ("AvAnalysisTill20Kepoch_onlyW.png\n"
"Program.30_07_2017_14_03_31.1.json\n"
"Program.30_07_2017_14_03_31.1.mat\n"
"Program.30_07_2017_14_03_31.10002.mat\n"
"Program.30_07_2017_14_03_31.10005.mat\n"
"Program.30_07_2017_14_03_31.10005.av.mat\n"
"Program.30_07_2017_14_03_31.10005.mat\n"
"Program.30_07_2017_14_03_31.10008.mat\n"
"Program.30_07_2017_14_03_31.10011.mat\n"
"Program.30_07_2017_14_03_31.10014.mat\n"
"Program.30_07_2017_14_03_31.10017.mat\n"
"Program.30_07_2017_14_03_31.1002.mat\n"
"Program.30_07_2017_14_03_31.10020.mat\n"
"Program.30_07_2017_14_03_31.10023.mat\n"
"Program.30_07_2017_14_03_31.10026.mat\n"
"Program.30_07_2017_14_03_31.10029.mat\n"
"Program.30_07_2017_14_03_31.10032.mat\n"
"Program.30_07_2017_14_03_31.10035.mat\n"
"Program.30_07_2017_14_03_31.10038.mat\n"
"Program.30_07_2017_14_03_31.10041.mat\n"
"Program.30_07_2017_14_03_31.10044.mat\n"
"Program.30_07_2017_14_03_31.10047.mat\n"
"Program.30_07_2017_14_03_31.1005.mat\n"
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19950.mat\n"
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19953.mat\n"
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19956.mat\n"
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19959.mat\n"
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19962.mat\n"
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19965.mat\n"
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19968.mat\n"
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19971.mat\n"
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19974.mat\n"
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19977.mat\n"
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19980.mat\n"
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19983.mat\n"
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19986.mat\n"
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19989.mat\n"
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19992.mat\n"
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19995.mat\n"
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.19998.mat\n"
"UBUNTU_30x300w30r3E-2.02_08_2017_12_09_36.20000.mat\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.