$re = '/<([^<>]|(?R))*>/m';
$str = '<TEXTTYPE:<F3>><MSD:100><TEXTTYPE:),(1/3))<ARROW LEFT><ARROW LEFT><ARROW LEFT><ARROW LEFT><ARROW LEFT><ARROW LEFT><ARROW LEFT>><MSD:100><TEXTTYPE:<CTRLD><SHIFTD>]<SHIFTU><CTRLU>><MSD:500><TEXTTYPE:<ARROW LEFT>pow(>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);