re = /^".*?"$|^'.*?'$/m
str = '{k} must-match
{} jhtgj {} must-match
{ } not-match
\'"{firstName} {lastName}" <{email}>\'
{0.concat("8a b c d e", 6)} must-match
s df s sd{"one fielslkein 897sd\'f8\'97f 89s(*Y*&Sc {}d name".toFixed(7 , 8)} must-match
s df s sd{\'one fielslkein "897sd"f897f 89s(*Y*&Sc {}d name\'.toFixed(7 , 8)} must-match
sd{0.concat("8a b c d e", 6)} must-match
ascdac{ "one fieldname" } must-match
ascdac{ "onefi eldname".kk(kk, "dd") } must-match
{onefieldname.toFixed(7 , 8)} must-match
dfgsdg { "onefieldname".toFixed(7 , 8)} must-match
{onefieldname: "toFixed(7 , 8)"} not-match
{"onefieldname": "toFixed(7 , 8)"} not-match
{ "onefiel dname" : "toFixed(7 , 8)"} not-match
{ "onefiel dname": 8} not-match
{ "o dna" : {onefi eldname.l(7 , 8)} } not-match
{ "o dna" : {"onefi eldname".l(7 , 8)} } match-inner
{ "f dna" : {"onefi eldname".toFixed(7 , 8) }} match-inner
{ "f dna" : { "onefi eldname".toFixed(7 , 8) }} match-inner
{ "o dme" : {onefieldname.toFixed(7 , 8)} } match-inner
{ "on dname" : { onefieldname.toFixed(7 , 8)} } match-inner
{ {}: "{}" }
"asdads"
concat("1aa")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end