#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(подрост:\s+)(?<composition>[0-9А-Я]+)?\s?(?<age>\(\d+\))?\s?(?<height>\d+,\d\sм)?\s?,?\s?(\d+,\d\s+тыс.шт\/га),?([А-Яа-я]+)?"
Local $sString = "подрост: 10Е (20) 3,0 м, 1,5 тыс.шт/га" & @CRLF & _
"подрост: 10Е 3,0 м, 1,5 тыс.шт/га" & @CRLF & _
"подрост: 10Е 1,5 тыс.шт/га" & @CRLF & _
"подрост: 6ЯС3И1ОР (15) 2,0 м, 3,0 тыс.шт/га,благонадежный"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")