re = /^@[^=]*?=(?<badgeinfo>.*?);[^=]*?=(?<badges>.*?);c[^=]*?=(?<clientNonce>.*?);[^=]*?=(?<color>.*?);[^=]*?=(?<name>.*?);[^=]*?=(?<emojis>.*?);[^=]*?=(?<firstMsg>.*?);[^=]*?=(?<flags>.*?);[^=]*?=(?<id>.*?);[^=]*?=(?<mod>.*?);[^=]*?=(?<returningChatter>.*?)[^=]*?=(?<roomId>.*?);[^=]*?=(?<sub>.*?);[^=]*?=(?<tmi>.*?);[^=]*?=(?<turbo>.*?);[^=]*?=(?<userId>.*?);[^=]*?=(?<userType>.*?):[^=]*? :(?<message>.*)/m
str = '@badge-info=;badges=broadcaster/1,premium/1;client-nonce=8f8a16f3582a7b95bc270350fe1a635d;color=#D2691E;display-name=buckybubba;emotes=;first-msg=0;flags=;id=26e18d04-2e0d-41d9-a8e9-925a434d7142;mod=0;returning-chatter=0;room-id=460209762;subscriber=0;tmi-sent-ts=1690833107242;turbo=0;user-id=460209762;user-type= :buckybubba!buckybubba@buckybubba.tmi.twitch.tv PRIVMSG #buckybubba :Test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end