// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-zA-Z0-9]*[a-zA-Z]+[a-zA-Z0-9]*\.[a-zA-Z0-9]*\.[a-zA-Z0-9]*|[a-zA-Z0-9]*\.[a-zA-Z0-9]*[a-zA-Z]+[a-zA-Z0-9]*\.[a-zA-Z0-9]*)(~|\-|\+){0,1}[a-zA-Z0-9]+$").unwrap();
let string = "//good
rc0.05.00
0rc.05.00
0.rc05.00
0.05rc.00
rc0.rc05.00
rc0.05rc.00
0.0.0sr1+asdf
0.0.0sr1+asdf
v1c.1.asdf
errhand.LSD.asdf+dfsg
1.c1.asdf
1.1c.asdf
c1.1.asdf
c1c.1.asdf
1.c1cc.asadf~dsf
//bad
1.1
1.1.1
1.00.00
v1c.1.
1.v1c.
1.01.01~sdgf
1.v1c.asdf-sadf+asdf
~1c.1c.0
1c.1~c.0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}