const regex = new RegExp('^(?=.*[A-Za-z])(?=.*\\d)[A-Za-z\\d$@$!%*?&#]{6,}$', 'gm')
const str = `pa1234
pa#123
pa#\\123
pa1234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}