import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "insert\\s+into\\s+casi_tassazione\\s+(\\(.+?\\))\\s+values\\s+(\\(.+\\));";
final String string = "INSERT INTO CASI_TASSAZIONE (ID_CSTASS, ID_DCHFIS, ESERCIZIO, PROGRESSIVO, ID_PARENT_CSTASS, NO_REINTIMAZIONE, ID_PERGIU, ID_STORGN, TASSAZIONE_UFFICIO, ID_OWNER, ID_WORKER, ID_UNTORG, PRIMO_GIORNO_ESECZ, ULTIMO_GIORNO_ESECZ, DATA_CAMBIO_STORGN, DATA_INS, INS_USERID, DATA_UPD, UPD_USERID) VALUES (100001, 100000, 2009, 0, NULL, 0, 100001, 2, 0, 10000, 10000, @idUnitaOrganizzativa, '2009-01-01', '2009-12-31', '2009-04-24', '2009-04-24 10:09:07.115', 'JUNIT', '2009-04-24 10:09:09.894', 'JUNIT');\n\n"
+ " INSERT INTO CASI_TASSAZIONE\n"
+ " (ID_CSTASS, ID_DCHFIS, ESERCIZIO, PROGRESSIVO, ID_PARENT_CSTASS, NO_REINTIMAZIONE, ID_PERGIU, ID_STORGN, TASSAZIONE_UFFICIO, ID_OWNER, ID_WORKER, ID_UNTORG, PRIMO_GIORNO_ESECZ, ULTIMO_GIORNO_ESECZ, DATA_CAMBIO_STORGN, DATA_INS, INS_USERID, DATA_UPD, UPD_USERID) VALUES (100001, 100000, 2009, 0, NULL, 0, 100001, 2, 0, 10000, 10000, @idUnitaOrganizzativa, '2009-01-01', '2009-12-31', '2009-04-24', '2009-04-24 10:09:07.115', 'JUNIT', '2009-04-24 10:09:09.894', 'JUNIT'),(ID_CSTASS, ID_DCHFIS, ESERCIZIO, PROGRESSIVO, ID_PARENT_CSTASS, NO_REINTIMAZIONE, ID_PERGIU, ID_STORGN, TASSAZIONE_UFFICIO, ID_OWNER, ID_WORKER, ID_UNTORG, PRIMO_GIORNO_ESECZ, ULTIMO_GIORNO_ESECZ, DATA_CAMBIO_STORGN, DATA_INS, INS_USERID, DATA_UPD, UPD_USERID) VALUES (100001, 100000, 2009, 0, NULL, 0, 100001, 2, 0, 10000, 10000, @idUnitaOrganizzativa, '2009-01-01', '2009-12-31', '2009-04-24', '2009-04-24 10:09:07.115', 'JUNIT', '2009-04-24 10:09:09.894', 'JUNIT');\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}