$re = '/\s+/';
$str = 'aaaaa
aaa aaa
aaa aaa
aaa
a a a a a ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);