$re = '/(?<=const )(.*)(?==\s*styled)/';
$str = 'export const foo =styled';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);