re = /(?:(?:(?<thld>[\w\-]*)(?:\.))?(?<sld>[\w\-]*))\.(?<tld>\w*)/
str = 'qsdqsd.co.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end