$re = '/^[0-9]*(?:[^0-9a-z][0-9]*)*$/m';
$str = '01230.123.1032,1032';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);