#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)(?i)PODATNIK\:[\s\a]*(?<NAZWA>[\S ]*)(?<KODPOCZTOWY>\d{2}-\d{3} )(?<LOKALIZACJA>[a-ż ]+)[\s\a]*ORYGINAŁ[\s\a]*\k<LOKALIZACJA>,[\s]*(?<DATA>\d{4}-\d{2}-\d{2})[\s\a]*(?<ULICA>[a-ż 0-9]*)[\s\a]*Bank[\s]*:[\s]*(?<BANK>[\w ]*)[\s\a]*NIP[\s]*:[\s]*(?<NIP>\d{3}-\d{3}-\d{3})[\s\a]*Konto[\s]*:[\s]*(?<KONTO>\d{26})[\s\a\S]*FAKTURA VAT[\s]*(?<NRFAKTURY>\d{2}\/\d{2}\/\d{4})*[\s\a]*Data wystawienia[\s\:]*(?<DATAWYSTAWIENIA>\d{4}-\d{2}-\d{2})[\s]*Data sprzedaży[\s\:]*(?<DATASPRZEDAZY>\d{4}-\d{2}-\d{2})[\s\a]*Na podstawie[\s\:]*(?<NAPODTSAWIE>[a-ż]\d{5}),[\s\a]*z dnia[\s]*:[\s]*(?<ZDNIA>\d{4}[-]?\d{2}[-]?\d{2})[\s\a]*NABYWCA[\s]*:[\s]*(?<NABYWCA>[\S ]*)[\s\a]*\(811\)[\s]*:[\s]*(?<ULICA2>[a-ż 0-9]*\d[a-z]{1,3} )(?<MIASTO>[a-ż]*)[\s\a]*,[\s\a]*(?<KODPOCZTOWY2>\d{2}[-]?\d{3})[\s\a]*N2P[\s]*:[\s]*(?<N2P>\d{3}[-]?\d{3}[-]?\d{2}[-]?\d{2})[\s\a]*Operator prowadzący[\s]*:[\s]*(?<OPERATOR>[a-ż ]*),[\s]*Tel.[\s]*:[\s]*(?<TEL>[0-9]{9}|[0-9 ]*)"
Local $sString = "PODATNIK:" & @CRLF & _
"Rogum Kable Sp. z o.o. 83-000 Pruszcz Gdański" & @CRLF & _
"ORYGINAŁ" & @CRLF & _
"Pruszcz Gdański, 2020-04-28" & @CRLF & _
"" & @CRLF & _
"Gruńwaldzka 66" & @CRLF & _
"" & @CRLF & _
"Bank: Bank Polska Kasa Opieki SA" & @CRLF & _
"" & @CRLF & _
"NIP : 000-111-111" & @CRLF & _
"" & @CRLF & _
"Konto: 57124012681111001033385998" & @CRLF & _
"" & @CRLF & _
"/" & @CRLF & _
"FAKTURA VAT 07/04/2020" & @CRLF & _
"Data wystawienia : 2020-04-28 Data sprzedaży : 2020-04-28" & @CRLF & _
" " & @CRLF & _
"Na podstawie : T59999, z dnia: 2019-12-28" & @CRLF & _
" " & @CRLF & _
"NABYWCA : Pojazdy Szynowe PESA Bydgoszcz S.A." & @CRLF & _
"(811) : Zygmunta Augusta 11avb Bydgoszcz, 85-082 " & @CRLF & _
"N2P : 554-031-17-75" & @CRLF & _
"Operator prowadzący : Łukasz Czajkowski, Tel.: 506234233, E-mail: l.czajkowski@rogum.com.pl" & @CRLF & _
"/" & @CRLF & _
"Poprzednie zaliczki/zadatki: Fzal 54/04/2020 2020-04-06 (246 000,00)" & @CRLF & _
"Lp" & @CRLF & _
"Nazwa pełna" & @CRLF & _
"Ilość" & @CRLF & _
"Jm" & @CRLF & _
"Cena" & @CRLF & _
"Wartość" & @CRLF & _
"Stawka" & @CRLF & _
"Wartość" & @CRLF & _
"Wartość" & @CRLF & _
"Indeks (K)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"NETTO PL" & @CRLF & _
"NETTO PLN" & @CRLF & _
"VAT" & @CRLF & _
"VAT PLN" & @CRLF & _
"BRUTTO PLN" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"LiHCH 0,6/1kV 3x1,5" & @CRLF & _
"200" & @CRLF & _
"m" & @CRLF & _
"2,70" & @CRLF & _
"540,00" & @CRLF & _
"23%" & @CRLF & _
"124,20" & @CRLF & _
"664,20" & @CRLF & _
"9124-1100-000-075" & @CRLF & _
"" & @CRLF & _
"2" & @CRLF & _
"LiHCH 0,6/1kV 3x1,5" & @CRLF & _
"86" & @CRLF & _
"m" & @CRLF & _
"2,70" & @CRLF & _
"232,20" & @CRLF & _
"23%" & @CRLF & _
"53,41" & @CRLF & _
"285,61" & @CRLF & _
"9124-1100-000-075" & @CRLF & _
"" & @CRLF & _
"PRZED ODLICZ. ZAL./ZAD. - Zestawienie podatku VAT" & @CRLF & _
"Netto" & @CRLF & _
"Stawka" & @CRLF & _
"VAT" & @CRLF & _
"Brutto" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"772,20" & @CRLF & _
"23%" & @CRLF & _
"177,61" & @CRLF & _
"949,81" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ODLICZENIE ZAL./ZAD. - Zestawienie podatku VAT" & @CRLF & _
"Netto" & @CRLF & _
"Stawka" & @CRLF & _
"VAT" & @CRLF & _
"Brutto" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"-772,20" & @CRLF & _
"23%" & @CRLF & _
"-177,61" & @CRLF & _
"-949,81" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"Zestawienie podatku VAT" & @CRLF & _
"Netto" & @CRLF & _
"" & @CRLF & _
"Stawka" & @CRLF & _
"VAT" & @CRLF & _
"" & @CRLF & _
"Brutto" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"RAZEM (2 Poz.)" & @CRLF & _
"" & @CRLF & _
"0,00" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"0,00" & @CRLF & _
"0,00" & @CRLF & _
"" & @CRLF & _
"SUMA OGÓŁEM" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"0,00" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"Słownie : zero złotych, zero groszy" & @CRLF & _
" " & @CRLF & _
"DO ZAPŁATY : 0,00 zł Rozliczono" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Sara Żołnowska" & @CRLF & _
" " & @CRLF & _
" . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . " & @CRLF & _
"podpis osoby upoważnionej pieczęć i podpis wystawiającego do odbioru Faktury VAT" & @CRLF & _
"Druk Streamsoft PRESTIŻ lic. 5529 v. 7.0.347.168 Str. 1 z 1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")