$re = '/^(?:([0-9]*)(?=[Dd]))?[Dd]?([0-9]+)*(?:([+-]?[0-9]*))$/m';
$str = 'd2
d2+1
d2-3
4d2
4d2+1
4d2-3
10
d20+1
+1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);