$re = '~(?<=<comment>)(?:(?!<\/comment>).)*~';
$str = '"<xml><comment>Lorem ipsum dolor sit amet[{\'name\' : \'Mario Rossi\'}]</comment></xml>"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);