package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)^(?:\D+)?(?:(?:[5-6](?:(?:\.|\,)[1-9])?)|(?:[6-7](?:(?:\.|\,)0)?))(?:(?:\s?pol)|"|''|\x60|'|´|”)?(?:.*)`)
var str = `4.5 polegadas (~ 64,3% relação tela-corpo)
5,5 polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3
5,5 polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3
5"-6" polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3
^(?:(6(?:\.|\,)0)|(5(?:\.|\,)[1-9]))(.*)
\s?(?:(?:\d+)(?:\.|\,)?(?:\d+)?)(?:"|''|\x60|'|´|”)
(?:(5(?:\.|\,)0)|(4(?:\.|\,)[1-9]))(.*)
(4(?:\.|\,)[1-9])(.*) => 4-5
(5(?:\.|\,)[0]))(.*) => 4-5`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}