#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Representatives:\s+(?<rep_name>.*)\(.*\)\s+((?<rep2_name>.*)?\s+\()?"
Local $sString = "----------------------------------------------" & @CRLF & _
"SESSION SUMMARY" & @CRLF & _
"----------------------------------------------" & @CRLF & _
"Representatives:" & @CRLF & _
" Amoz Abraham (ID: 23)" & @CRLF & _
" Jose Sandoval (ID: 25)" & @CRLF & _
"" & @CRLF & _
"Customer Name: [Pinned] SOUTHLAWN02" & @CRLF & _
"Customer's Public IP: 174.110.83.140:56969" & @CRLF & _
"Customer's Private IP: 10.5.65.90" & @CRLF & _
"" & @CRLF & _
"Session Start Time: 2020-05-15 17:03:22 US/Pacific" & @CRLF & _
"Session End Time: 2020-05-15 17:11:37 US/Pacific" & @CRLF & _
"Duration: 00:08:15" & @CRLF & _
"# Files Transferred: 0" & @CRLF & _
"# Files Moved: 0" & @CRLF & _
"# Files Deleted: 0" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"----------------------------------------------" & @CRLF & _
"SYSTEM INFORMATION RETRIEVED" & @CRLF & _
"----------------------------------------------" & @CRLF & _
"## General ## " & @CRLF & _
" " & @CRLF & _
"Version: Windows 10 Pro x64 " & @CRLF & _
"Computer Name: SOUTHLAWN02 " & @CRLF & _
"System BIOS: " & @CRLF & _
"Processor 1 Info: Intel(R) Core(TM) i5-9500 CPU @ 3.00GHz " & @CRLF & _
"Processor 2 Info: Intel(R) Core(TM) i5-9500 CPU @ 3.00GHz " & @CRLF & _
"Processor 3 Info: Intel(R) Core(TM) i5-9500 CPU @ 3.00GHz " & @CRLF & _
"Processor 4 Info: Intel(R) Core(TM) i5-9500 CPU @ 3.00GHz " & @CRLF & _
"Processor 5 Info: Intel(R) Core(TM) i5-9500 CPU @ 3.00GHz " & @CRLF & _
"Processor 6 Info: Intel(R) Core(TM) i5-9500 CPU @ 3.00GHz " & @CRLF & _
"Default Browser: Google Chrome " & @CRLF & _
"Default Browser Version: 81.0.4044.138 " & @CRLF & _
"Default Browser Location: C:\Program Files (x86)\Google\Chrome\Application\chrome.exe " & @CRLF & _
"Windows® Directory: C:\Windows " & @CRLF & _
"System Directory: C:\Windows\system32 " & @CRLF & _
"Time Zone: Eastern Daylight Time " & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")