$re = '/[\d]+[.]{0,1}[\d]+[x|X|*][\d]+[.]{0,1}[\d]+[x|X|*][\d]+[.]{0,1}[\d]+/m';
$str = '12*19.2*2000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);