const regex = /^(?:https?:\/\/)?(?:(?:www|gaming)\.)?youtube\.com\/(?:channel\/|(?:user\/)?)([a-z\-_0-9]+)\/?(?:[\?#]?.*)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:https?:\\\/\\\/)?(?:(?:www|gaming)\\.)?youtube\\.com\\\/(?:channel\\\/|(?:user\\\/)?)([a-z\\-_0-9]+)\\\/?(?:[\\?#]?.*)', 'i')
const str = `https://www.youtube.com/user/Vsauce`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}