$re = '/^[a-zA-Z][-_a-zA-Z0-9]{5,19}$/';
$str = '0341-86091234';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);