$re = '/^(?(DEFINE)(?\'word\'(?:[a-zA-Z0-9!?\'"&\.,+@%~$]|(?<! )-(?! ))+)(?\'words\'(?&word)(?: (?&word))*?)(?\'nothe\'(?<!, (?i:a))(?<!, (?i:the|les)))(?\'ver_prefix\'Rev|Proto|Alpha|Beta))(?\'title\'(?&words)(?¬he))(?\'subtitle\' - (?&words))*?(?\'upd\' (?:Update|DLC - (?&words)))?(?\'region\' \((?:(?:A|As|B|C|Ch|Nl|E|F|G|Gr|Hk|I|J|K|No|R|S|Sw|U|Uk|Tw|W))+\))?(?\'version\' \[(?:(?:(?&ver_prefix) )?(?:(?\'_ver\'[\da-zA-Z]+)(?:\.(?&_ver))+|\d\d\d\d-\d\d-\d\d(?:T\d+)?)|(?&ver_prefix)( (?:[A-Z]|\d+|early))?)\])?(?\'part\' \(Dis(?:c|k) \d+\))?(?\'language\' \((?\'_lang\'(?:F-)?(?:Ja|En|Fr|De|Es|It|Nl|Ca|Fi|No|Sv|Da|Zh(?:-Hant|-Hans)?|Pt|Ru|Ko|Pl))(?:,?(?&_lang))*\))?(?\'randomshit\'(?: \[DEMO\])?(?\'lossy\' \[LOSSY\])?(?: \[Sample\])?(?: \(Promo\))?(?: \(Unl\))?)(?\'features\' \[(?\'_feat\'[a-zA-Z]+)(?:, ?(?&_feat))*\])?(?\'ext\'\.(?:gbc|gb|nsp|xci|(nkit\.)?rvz|gcz|wbfs|wad|gba|type|cia|3ds|nds|nes|sfc|smc|n64|z64|wux|gg|md|sms|iso|pce|chd))$/m';
$str = 'Amazing Spider Man (UE).gb
Otto\'s Ottifanten - Baby Bruno\'s Nightmare (E) (En,Fr,De,Es).gb
Pokemon Kristall (G).gbc
A Hat in Time DLC - Nyakuza Metro [1.1.0].nsp
Pokemon Card GB2 - GR Dan Sanjou! (J).gbc
Asphalt 9 Legends [1.3.1].nsp
Animal Crossing New Horizons DLC - Special Order Ticket Pocket Camp tie-in campaign.nsp
Pokemon Pinball (E) (En,Fr,De,Es,It) [S,DMG].gbc
Arcade Hits - Moon Patrol & Spy Hunter (UE) [DMG].gbc
Daikatana (U) [Proto 2000-04-19] [DMG].gbc
Hang Time Basketball (E) (Unl).gbc
Pokemon Green (J) [1.0] (F-En).gb
LSDJ [9.2.L].gb
Keep Talking and Nobody Explodes Update [1.2.0].nsp
Sonic Mania Plus [1.0.4] (En,Ja,Fr,De,Es,It,Zh).xci
Spelunky [1.22.2a].nsp
Chrono Cross (U) (Disc 1).chd
Chrono Cross (U) (Disc 2).chd
Fear Effect 2 - Retro Helix (E) (Disc 1) (En,Fr,De).chd
Ren & Stimpy Show - Buckeroo$! (U).sfc
PGA European Tour Golf (E) [Beta B.29] (En,De).z64
007 - The World Is Not Enough (U) [Beta 21].z64
007 - The World Is Not Enough (U) [Beta 2.00].z64
Pokemon Yellow (UE) [C].gb
Shadowgate 64 - Trials of the Four Towers (U) [Beta] (En,Es).z64
Mario Kart Wii (U) (En,Fr,Es) [LOSSY].wbfs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);