import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![src|href]\\=\\\"(\\n*|\\s*)?)((?:https?):\\/\\/[\\-A-Z0-9+\\u0026\\u2019@#\\/%?=()~_|!:,.;]*[\\-A-Z0-9+\\u0026@#\\/%=~()_|])";
final String string = "http://www.naver.com\n"
+ "http://www.google.com\n"
+ "http://www.google.com\n"
+ "http://www.naver.com\n"
+ "https://www.naver.com\n"
+ "www.naver.com\n"
+ "http://naver.com\n"
+ "www.naver.com\n\n\n\n"
+ "<img style=\"vertical-align: top;\" alt=\"\" src=\" https://www.kita.net/mailclub/DailyTradeNews/images/gk_top_banner_191111.jpg\" border=\"0\">\n\n\n"
+ "<a target=\"_blank\" href=\"https://www.kita.net/asocGuidance/notice/noticeDetail.do?pageIndex=1&nIndex=1792315&indexArray=&sortArray=&searchReqType=detail&searchStartDate=&searchEndDate=&searchCommCode1=&searchCondition=TITLE&searchKeyword=\">\n\n"
+ "<a target=\"_blank\" href=\" https://www.kita.net/asocGuidance/notice/noticeDetail.do?pageIndex=1&nIndex=1792315&indexArray=&sortArray=&searchReqType=detail&searchStartDate=&searchEndDate=&searchCommCode1=&searchCondition=TITLE&searchKeyword=\">\n\n"
+ "<a target=\"_blank\" href=\"\n"
+ "https://www.kita.net/asocGuidance/notice/noticeDetail.do?pageIndex=1&nIndex=1792315&indexArray=&sortArray=&searchReqType=detail&searchStartDate=&searchEndDate=&searchCommCode1=&searchCondition=TITLE&searchKeyword=\">\n\n"
+ "<a target=\"_blank\" href= \" \n\n"
+ "https://www.kita.net/asocGuidance/notice/noticeDetail.do?pageIndex=1&nIndex=1792315&indexArray=&sortArray=&searchReqType=detail&searchStartDate=&searchEndDate=&searchCommCode1=&searchCondition=TITLE&searchKeyword=\">\n\n\n\n"
+ "(?<!\\=\\\"(\\n|\\s).?)((?:https?):\\/\\/[\\-A-Z0-9+\\u0026\\u2019@#\\/%?=()~_|!:,.;]*[\\-A-Z0-9+\\u0026@#\\/%=~()_|])\n\n\n\n"
+ "(^|[\\s\\n]|<[A-Za-z]*\\/?>)((?:https?|ftp):\\/\\/[\\-A-Z0-9+\\u0026\\u2019@#\\/%?=()~_|!:,.;]*[\\-A-Z0-9+\\u0026@#\\/%=~()_|])\n\n"
+ "//최종\n"
+ "(?<![src|href]\\=\\\"(\\n*|\\s*)?)((?:https?):\\/\\/[\\-A-Z0-9+\\u0026\\u2019@#\\/%?=()~_|!:,.;]*[\\-A-Z0-9+\\u0026@#\\/%=~()_|])";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}