const regex = /(\b\w)|(.)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b\\w)|(.)', 'g')
const str = `alan dos santos silva`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);