$re = '/^[1-9]{1}[0-9]{9}[02468]{1}$/m';
$str = '23888065560';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);