#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[\[Kategória:[^\]\]]+\]\]"
Local $sString = "[[Kategória:Rakúski anarchisti]]" & @CRLF & _
"[[Kategória:Rakúski filozofi]]" & @CRLF & _
"[[Kategória:Osobnosti z Viedne]]" & @CRLF & _
"[[Kategória:Rakúski automobiloví pretekári|F1]]" & @CRLF & _
"[[Kategória:Rakúski športovci|Automobiloví pretekári]]" & @CRLF & _
"[[Kategória:Automobiloví pretekári podľa štátu|Rakúsko]]" & @CRLF & _
"" & @CRLF & _
"[[Kategória: ]]" & @CRLF & _
"<comment>-[[Kategória:Literárne žánre]]; -[[Kategória:Filmové žánre]] pomocou použitia HotCat</comment>" & @CRLF & _
"<comment>+[[Kategória:Zaniknuté monarchie]]; +[[Kategória:Zaniknuté štáty Európy]]; +[[Kategória:Zaniknuté štáty Ázie]] pomocou použitia HotCat[[Kategória: ]]</comment>" & @CRLF & _
"<comment>odobratá [[Kategória:Dvojtisícovky]]; pridaná [[Kategória:Dvojtisícovky na Slovensku]] pomocou použitia HotCat</comment>" & @CRLF & _
"<comment>-[[Kategória:Technika]]; ±[[Kategória:Biológia]]→[[Kategória:Akvaristika]] pomocou použitia HotCat</comment>" & @CRLF & _
"<comment><!-- [[Kategória:Civilizácia]] -->, [[Kategória:Civilizácie]]</comment>" & @CRLF & _
"[[Kategória:User fa|{{PAGENAME}}]][[Kategória:User fa-N|{{PAGENAME}}]] &#1586;&#1576;&#1575;&#1606; &#1605;&#1575;&#1583;&#1585;&#1740; &#1575;&#1740;&#1606; &#1705;&#1575;&#1585;&#1576;&#1585; &#1575;&#1587;&#1578;</span><hr/><span style="font-size: 8pt;">This user is a native speaker of '''[[:Kategória:User fa|Persian]]'''.</span>" & @CRLF & _
"" & @CRLF & _
"odobratá [[Kategória:Osobnosti z Málagy]]; pridaná [[Kategória:Osobnosti z Malagy]]" & @CRLF & _
"" & @CRLF & _
"Toto nechceme:" & @CRLF & _
"Taktiež môžete zaradiť článok do tzv. kategórie s ostatnými súvisiacimi článkami. Stačí ak napíšete <nowiki>[[Kategória:]]</nowiki> a názov kategórie medzi dvojbodku a hranaté zátvorky. Viac informácií nájdete na stránke o [[Wikipédia:Kategórie|kategóriách]]." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"1. I have a two pets - dog and a cat" & @CRLF & _
"2. I have a pet - dog"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")