using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Phone.*(?<=\s)([\dA-z]+)";
string input = @"Phone ,*$ 1233344dfdfF
Phone123";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}