$re = '/^\d{4}\s?[A-Z]{2}$/m';
$str = '3314 BSa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);