# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\.GetModification(?:String|Number|Bool|Object|Array)\((?:\s*[\"']([\w\-]+)['\"]\s*,\s*([\"'][^\"]*['\"]|[+-]?(?:\d*[.])?\d+|true|false|False|True)(?:\s*,\s*(?:true|false|\d+|\"[^\"]*\"))?\s*\))?"
test_str = (" discountName, err := fsVisitor.GetModificationString(\"btnColor\", \"VString\", true)\n"
" discountName, err := fsVisitor.GetModificationNumber(\"btnSize\", 13, true)\n"
" discountName, err := fsVisitor.GetModificationBool(\"showBtn\", false, true)\n\n"
" discountName, err := fsVisitor.GetModificationString(\"btnColor\", \"VString\")\n"
" discountName, err := fsVisitor.GetModificationNumber(\"btnSize\", 13)\n"
" discountName, err := fsVisitor.GetModificationBool(\"showBtn\", false)\n\n"
" discountName, err := fsVisitor.GetModificationString(\"btnColor\", \"VString\")\n"
" discountName, err := fsVisitor.GetModificationNumber(\"btnSize\", \"red, green, blue\")\n"
" discountName, err := fsVisitor.GetModificationBool(\"showBtn\", \"(false, red)\")\n\n"
" discountName, err := fsVisitor.GetModificationBool(showBtn, \"(false, red)\")")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.