# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(PI~)([0-9]*)"
test_str = ("MSH|^~\\&|EPIC|UMCG|||20180927143440||ADR^A19|18093|P|2.4|||||||||||\n"
"MSA|CA|20180927023440||\n"
"QRD|20180927|R|I|20180927|||1^RD|1414141|DEM\n"
"EVN|A19|20180927143440|||^^^^^^^^^^^^^||\n"
"PID|1||1414141^^^UMCG^PI~109819226||PROEFPERSOON&&PROEFPERSOON^J^X Y Z^^^^L^^^^NL1~PROEFPERSOON&&PROEFPERSOON^PIET^^^^^N^^^^NL1||19700101|M|PROEFPERSOON^PIET^^||PROEFLAAN 1C&PROEFLAAN&1C^^GRONINGEN^^9713GZ^NLD^L||050-1234567^P^PH^^^050^1234567~^NET^Internet^PIET@PROEFPERSOON.com~06-12345678^P^CP^^^06^12345678|06-87654321^P^PH^^^06^87654321|NEDERLANDS|||19764||||||Y||||||N||\n"
"ROL|1|UP|PP^Primary Care Provider|01001234^Huisarts^H^^^^^^Vektis^L|||||01^Huisartsen^Vektis||Straatweg 2&Straatweg&2^^Groningen^^9723AA^^O|050-3134102^WPN^PH~^NET^X.400^800013630\n"
"PV1|1|I|UG_V_A1VA^4^4-1^10^^^^^UMCG A1VA^^DEPID|NB||||||||||WOON|||||19764|CZ||||||||||||||||||||||||20180926143019||||||99996||||\n"
"AL1|1|SYSTEMISCH|^GEEN BEKENDE ALLERGIEEN^||||||\n"
"IN1|1||7119^^^UZOVI^PAYORID|CZ GROEP ZORGVERZEKERAAR UA (7119)|POSTBUS 4400&POSTBUS 4400&^^GOES^^4460CZ^||0113-274727^^^^^0113^274727|||||||||PROEFPERSOON^J^X Y Z.^^|Zelf|||Accepteren||1|||Ja||||||||||2552|ABC0123|||||||||||BEIDE||\n"
"IN2|||||Verzekeraar||||||||||||||||||||||||||||||||||||||||||||||||||||||||ABC0123|||||||||\n"
"L|1|UP|PP^Primary Care Provider|01001234^Huisarts^H^^^^^^Vektis^L|||||01^Huisartsen^Vektis||Straatweg 2&Straatweg&2^^Groningen^^9723AA^^O|050-3134102^WPN^PH~^NET^X.400^800013630\n"
"")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.