// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)b+a+b+").unwrap();
let string = "Dear student,
Please find your College bill attached. If, after reading the following notes, you have any queries about your bill, then contact studentbilling@christs.cam.ac.uk
Explanatory Notes to your College Bill
Fees
Fees will appear as “University Fees” or “College Fees” as appropriate. If all or part of your fees are funded by a fee loan from the Student Loans Company or by a sponsor this portion of your fees will not appear on your bill. Fees for home and EU undergraduate students are charged 25%, 25%, 50% in Michaelmas, Lent and Easter terms respectively, with 1/3 fees for all other students charged each term. Sponsors will receive one bill in Michaelmas term each year.
Catering Charges
If you take meals in formal hall or pay for meals or drinks using your university card in Upper Hall or the Buttery or New Court Bars these will appear on your bill in the following term as “Catering charges – “ with the term name appended. This may include charges for guest rooms if you have used them and any charges incurred in the library. The items that make up this charge can be reviewed on the meal booking system on the College intranet by clicking on the ‘EPOS’ tab. If you have a query about your catering charges please contact cateringoffice@christs.cam.ac.uk*
Prepayment Kitchen Estimates
In your first term at Christs College you will be charged an estimate against the charges you may make during that term, which will be labelled “Catering Account estimate – “, with the term name appended.
In the next term you will see an entry that reverses this estimate, labelled Catering Account estimate returned – “, with the term indicating when it was charged and a new estimate charged for the forthcoming term. This new estimate will be based on your actual expenditure in the previous term unless your actual expenditure was under £50, in which case you will not be charged an estimate. NB Graduate students are not charged an estimate on their Long Vacation bills, when their Easter Term estimate is returned.
Accommodation charges
Accommodation charges will be labelled “Rent”, followed by the period covered. Undergraduates termly rent covers the ‘normal period of residence’. Any accommodation provided outside of this will be charged on a separate line. If you have a query about rent charges on your bill contact accommodation@christs.cam.ac.uk *
Graduate students generally pay a holding deposit for accommodation prior to arriving at College. This will be credited to your first bill providing that you take up the accommodation that has been booked for you.
College Awards
Bursaries and academic awards will appear as a credit on your bill, labelled “Christ’s College Award “ with the name of the award if applicable. Depending on the award it will either be credited termly or in Michaelmas Term. If PhD students’ awards are greater than any fees charged to their account the excess of award over fees will be split in four and credited in Michaelmas, Lent and Easter terms and Long Vacation, with the balance split to match the pattern of fee charges.
Scholars whose course continues the following year receive an award of £100 in Lent term.
Charity Subscriptions
The student body at Christ’s has a proud record of fundraising for those less fortunate than themselves. One way in which this is done is by opting to have ‘charity subs’ added to your college bill. If you opt into this a charge of £5 in Michaelmas, Lent and Easter term will appear on your bill. If you opt in you are free to opt out at any time in the future. A ballot is held in Michaelmas Term to decide which charities will benefit from this.
Other Charges
There are various other charges that may appear on your bill that should be self-explanatory, such as boat club subs (if you have been a member of the Boat Club), lost university cards, book awards, scholars’ photos and so on.
*If your query is with regard to the billing of these charges, for example if you think you have been billed twice for something, then contact studentbilling@christs.cam.ac.uk rather than using the relevant departmental email address.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}