#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:Nr.\s*nota\s*Folha\s*Data\s*preg.o\n(?<numNota>\d+)\s*(?<numFolha>\d+)\s*(?<dataPregao>\d{2}\/\d{2}\/\d{4})\s*(?<corretora>.+)\n(?:1-BOVESPA\s*.*\n)+Resumo\s*dos\s*Neg.cios\s*)"
Local $sString = "Nr. nota Folha Data pregão" & @CRLF & _
"2807356 1 02/03/2020" & @CRLF & _
"CLEAR CORRETORA - GRUPO XP" & @CRLF & _
"1-BOVESPA C VISTA GERDAU METPN ED N1 100 8,00 800,00 D" & @CRLF & _
"1-BOVESPA C VISTA ITAUSAPN EDJ N1 200 12,10 2.420,00 D" & @CRLF & _
"1-BOVESPA C VISTA ITAUSAPN EDJ N1 D 500 12,00 6.000,00 D" & @CRLF & _
"1-BOVESPA V VISTA ITAUSAPN EDJ N1 D 100 12,11 1.211,00 C" & @CRLF & _
"1-BOVESPA V VISTA ITAUSAPN EDJ N1 D 100 12,11 1.211,00 C" & @CRLF & _
"Resumo dos Negócios " & @CRLF & _
"Debêntures 0,00" & @CRLF & _
"Vendas à vista 2.422,00" & @CRLF & _
"Compras à vista 9.220,00" & @CRLF & _
"Opções - compras 0,00" & @CRLF & _
"Opções - vendas 0,00" & @CRLF & _
"Operações à termo 0,00" & @CRLF & _
"Valor das oper. c/ títulos públ. (v. nom.) 0,00" & @CRLF & _
"Valor das operações 11.642,00" & @CRLF & _
"Resumo Financeiro " & @CRLF & _
"Clearing " & @CRLF & _
"Valor líquido das operações 6.798,00 D" & @CRLF & _
"Taxa de liquidação 2,83 D" & @CRLF & _
"Taxa de Registro 0,00 D" & @CRLF & _
"Total CBLC 6.800,83 D" & @CRLF & _
"Bolsa " & @CRLF & _
"Taxa de termo/opções 0,00 D" & @CRLF & _
"Taxa A.N.A. 0,00 D" & @CRLF & _
"Emolumentos 0,39 D" & @CRLF & _
"Total Bovespa / Soma 0,39 D" & @CRLF & _
"Custos Operacionais " & @CRLF & _
""" " & @CRLF & _
"Taxa Operacional 0,00 D" & @CRLF & _
"Execução 0,00 " & @CRLF & _
"Taxa de Custódia 0,00 " & @CRLF & _
"Impostos 0,00 " & @CRLF & _
"I.R.R.F. s/ operações, base R$0,00 0,00 " & @CRLF & _
"Outros 0,00 C" & @CRLF & _
"Total Custos / Despesas 0,00 D" & @CRLF & _
"Nr. nota Folha Data pregão" & @CRLF & _
"3408171 1 11/03/2020" & @CRLF & _
"CLEAR CORRETORA - GRUPO XP" & @CRLF & _
"1-BOVESPA C VISTA VIVER ON NM 100 1,79 179,00 D" & @CRLF & _
"Resumo dos Negócios " & @CRLF & _
"Debêntures 0,00" & @CRLF & _
"Vendas à vista 0,00" & @CRLF & _
"Compras à vista 179,00" & @CRLF & _
"Opções - compras 0,00" & @CRLF & _
"Opções - vendas 0,00" & @CRLF & _
"Operações à termo 0,00" & @CRLF & _
"Valor das oper. c/ títulos públ. (v. nom.) 0,00" & @CRLF & _
"Valor das operações 179,00" & @CRLF & _
"Resumo Financeiro " & @CRLF & _
"Clearing " & @CRLF & _
"Valor líquido das operações 179,00 D" & @CRLF & _
"Taxa de liquidação 0,04 D" & @CRLF & _
"Taxa de Registro 0,00 D" & @CRLF & _
"Total CBLC 179,04 D" & @CRLF & _
"Bolsa " & @CRLF & _
"Taxa de termo/opções 0,00 D" & @CRLF & _
"Taxa A.N.A. 0,00 D" & @CRLF & _
"Emolumentos 0,00 D" & @CRLF & _
"Total Bovespa / Soma 0,00 C" & @CRLF & _
"Custos Operacionais " & @CRLF & _
""" " & @CRLF & _
"Taxa Operacional 0,00 D" & @CRLF & _
"Execução 0,00 " & @CRLF & _
"Taxa de Custódia 0,00 " & @CRLF & _
"Impostos 0,00 " & @CRLF & _
"I.R.R.F. s/ operações, base R$0,00 0,00 " & @CRLF & _
"Outros 0,00 C" & @CRLF & _
"Total Custos / Despesas 0,00 D" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")