package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[:][a-zA-Z]+[\s][=][>]`)
var str = `:id => `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}