re = /(.*)([\p{Arabic}]{3})[^\p{Arabic}]{0,7}([\p{Arabic}]{3})[^\p{Arabic}]{0,7}([\p{Arabic}]{4}).*/
str = '٩٠٥٣٣٤٠٠٦٩٠٢'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end