$re = '/\..+\.py.[0-9]+~/m';
$str = '.main.py.3340702474~';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);