re = /^\s+|\s+$/m
str = 'value
value
value
value
value
value
value
value value
abc def ghi
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end