package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<prod_no>[\w.]*)µ&£(?<prod_label>[^µ&£]*)µ&£(?<prod_category>[^µ&£]*)µ&£(?<cnk>[^µ&£]*)µ&£(?<pzn>[^µ&£]*)µ&£(?<cip>[^µ&£]*)µ&£(?<ean>[^µ&£]*)µ&£(?<cefip>[^µ&£]*)µ&£(?<country>[^µ&£]*)µ&£$`)
var str = `F0002051µ&£ABIES NIGRA BOIR GRAN 4CH 80µ&£µ&£µ&£µ&£µ&£µ&£µ&£Fµ&£
B000614172µ&£FADE OUT POT 60MLµ&£µ&£µ&£µ&£µ&£µ&£µ&£Bµ&£
F0011050µ&£ACONITUM NAPEL GRAN 4CH 80µ&£µ&£µ&£µ&£µ&£µ&£µ&£Fµ&£
F0011073µ&£ACONITUM NAPEL GRAN 5CH 80µ&£µ&£µ&£µ&£µ&£µ&£µ&£Fµ&£
F0011096µ&£ACONITUM NAPEL GRAN 7CH 80µ&£µ&£µ&£µ&£µ&£µ&£µ&£Fµ&£
F0011104µ&£ACONITUM NAPEL GRAN 9CH 80µ&£µ&£µ&£µ&£µ&£µ&£µ&£Fµ&£
F0011127µ&£ACONITUM NAPEL GRAN 15CH 80µ&£µ&£µ&£µ&£µ&£µ&£µ&£Fµ&£
F0011133µ&£ACONITUM NAPEL GRAN 30CH 80µ&£µ&£µ&£µ&£µ&£µ&£µ&£Fµ&£
F0011162µ&£ACONITUM NAPEL GLOB 7CH 1 DOSEµ&£µ&£µ&£µ&£µ&£µ&£µ&£Fµ&£
F4459818µ&£B/VARISMA1 SEDUCT AF C CANEL á1µ&£µ&£µ&£µ&£µ&£µ&£µ&£Fµ&£
F4459824µ&£B/VARISMA1 SEDUCT AF N CANEL 1µ&£µ&£µ&£µ&£µ&£µ&£µ&£Fµ&£
F4459830µ&£B/VARISMA1 SEDUCT AF C CANEL 2µ&£µ&£µ&£µ&£µ&£µ&£µ&£Fµ&£
F4459847µ&£B/VARISMA1 SEDUCT AF N CANEL 2µ&£µ&£µ&£µ&£µ&£µ&£µ&£Fµ&£
F4459853µ&£B/VARISMA1 SEDUCT AF C CANEL 3µ&£µ&£µ&£µ&£µ&£µ&£µ&£Fµ&£
F4459876µ&£B/VARISMA1 SEDUCT AF N CANEL 3µ&£µ&£µ&£µ&£µ&£µ&£µ&£Fµ&£
`
var substitution = "$2µ&£$3µ&£$4µ&£$5µ&£$6µ&£$7µ&£$8µ&£$9µ&£\\N"
fmt.Println(re.ReplaceAllString(str, substitution))
}