import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(1\\s?)?(\\(\\d{3}\\)\\s?|\\d{3}[\\-|\\s]?)(\\d{3}[\\-|\\s]?)(\\d{4})";
final String string = "555-555-5555\n"
+ "(555)555-5555\n"
+ "(555) 555-5555\n"
+ "555 555 5555\n"
+ "5555555555\n"
+ "1 555 555 5555\n\n\n"
+ "(555-555-5555\n\n"
+ "1(555)555-5555";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}