$re = '/.*\(19[1-8]\d\)/m';
$str = '1 The Shawshank Redemption (1994)
2 The Godfather (1972)
3 The Godfather: Part II (1974)
4 Pulp Fiction (1994)
5 The Good, the Bad and the Ugly (1966)
6 The Dark Knight (2008)
7 12 Angry Men (1957)
8 Schindler\'s List (1993)
9 The Lord of the Rings: The Return of the King (2003)
10 Fight Club (1999)';
$subst = "I";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;