#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(S\w.*\d[:])|(([0-9.]+|(-[0-9.]+)))|([A-Z]{2}\b)"
Local $sString = "ACTIONS: " & @CRLF & _
" [ { LONGITUDES: " & @CRLF & _
" { SHUTTLE_LON_A6: [ 748, [ 'CI', 76.5, 980.5 ] ]," & @CRLF & _
" SHUTTLE_LON_A5: " & @CRLF & _
" [ 271," & @CRLF & _
" [ 'CL', 0, 76.5 ]," & @CRLF & _
" [ 'CI', 76.5, 980.5 ]," & @CRLF & _
" [ 'CL', 980.5, 1057 ] ]," & @CRLF & _
" SHUTTLE_LON_A4: [ 129 ]," & @CRLF & _
" SHUTTLE_LON_A3: [ 107 ]," & @CRLF & _
" SHUTTLE_LON_A2: [ -35 ]," & @CRLF & _
" SHUTTLE_LON_A1: [ -57 ] }," & @CRLF & _
" LATITUDES: { SHUTTLE_LAT_1: [ [ 1057 ] ] } }," & @CRLF & _
" { LONGITUDES: " & @CRLF & _
" { SHUTTLE_LON_A6: [ 978, [ 'CL', 76.5, 980.5 ] ]," & @CRLF & _
" SHUTTLE_LON_A5: " & @CRLF & _
" [ 727," & @CRLF & _
" [ 'CL', 0, 76.5 ]," & @CRLF & _
" [ 'CI', 76.5, 980.5 ]," & @CRLF & _
" [ 'CL', 980.5, 1057 ] ]," & @CRLF & _
" SHUTTLE_LON_A4: [ 250, [ 'CI', 76.5, 980.5 ] ]," & @CRLF & _
" SHUTTLE_LON_A3: [ 20, [ 'CL', 76.5, 980.5 ] ]," & @CRLF & _
" SHUTTLE_LON_A2: [ -122 ]," & @CRLF & _
" SHUTTLE_LON_A1: [ -144 ] }," & @CRLF & _
" LATITUDES: " & @CRLF & _
" { SHUTTLE_LAT_1: " & @CRLF & _
" [ [ 20.5, [ 'CI', 0, 1100 ] ]," & @CRLF & _
" [ 34.5, [ 'CI', 0, 1100 ] ]," & @CRLF & _
" [ 58.5, [ 'CI', 0, 1100 ] ]," & @CRLF & _
" [ 76.5," & @CRLF & _
" [ 'CL', 0, 271 ]," & @CRLF & _
" [ 'CI', 271, 727 ]," & @CRLF & _
" [ 'CL', 727, 1100 ] ]," & @CRLF & _
" [ 980.5," & @CRLF & _
" [ 'CL', 0, 271 ]," & @CRLF & _
" [ 'CI', 271, 727 ]," & @CRLF & _
" [ 'CL', 727, 1100 ] ]," & @CRLF & _
" [ 998.5, [ 'CI', 0, 1100 ] ]," & @CRLF & _
" [ 1022.5, [ 'CI', 0, 1100 ] ]," & @CRLF & _
" [ 1036.5, [ 'CI', 0, 1100 ] ]," & @CRLF & _
" [ 1057, [ 'CL', 0, 1100 ] ]," & @CRLF & _
" [ 1057 ] ] } } ] } ]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")