using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((0?[x|X])|#)?[0-9,A-F,a-f]{8}";
string input = @"werwerwer 0x00000258qqdwef 4123r31ed0x0xxx00x0x00000001wefv sdfgsdgfdsfghsdfg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}