re = /^(|(?:.|\n)+\n)From:[\s\t]*((?:.|\n)*?)(|\n\S(?:.|\n)*)$/ix
str = 'from: grtrtr
ghhjjyjkyrur6uy yu6yu'
# Print the match result
str.match(re) do |match|
puts match.to_s
end