// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[(A-H|J-N|P|R-Z|0-9)]{17}\b").unwrap();
let string = "The VIN number on a vehicle is a 17 alpha-numeric characters and must NOT contain the letters I, O or Q (to avoid confusion with the similar looking digits).
So, for example, SALVA2AE4EH877322 is valid, but SALVO2AE4EH877322 is not.
By using the \\b word boundary token, we can match in quotes \"SALVA2AE4EH877482\", brackets (SALVA2AE4EH877998) or other boundaries that people may use <SALVA2AE4EH877002>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}